RESPUESTAS ALGORITMOS UNIDAD 2

1
Puntos: 1
En la lección 7 de la unidad 2 se hace una definición de lo que significa un algoritmo, la respuesta más acertada es:
Seleccione una respuesta.
Es un conjunto ordenado y finito de instrucciones, que permiten la resolución de un determinado problema.
Correcto
Puntos para este envío: 1/1.
Question2
Puntos: 1
En el capitulo 4 lección 4: se hace referencia al al herramienta Dfd, la cual permite:...
Seleccione una respuesta.
Correcto
Puntos para este envío: 1/1.
Question3
Puntos: 1
En la lección 3 se toma el tema de los condicionales, el cual permite:?
Seleccione una respuesta.
Permite tomar una decisión
Correcto
Puntos para este envío: 1/1.
Question4
Puntos: 1
La lección 11, hace referencia a las funciones
las funciones permiten:
Seleccione una respuesta.
Dividir un programa principal en varios subprogramas
Correcto
Puntos para este envío: 1/1.
Question5
Puntos: 1
En la lección 8 se trabaja las estructuras de selección en los algoritmos. Seleccione la estructura de selección doble acorde a lo presentado
Seleccione una respuesta.
esta es la estructura correcta Si .. Si_No ...
Correcto
Puntos para este envío: 1/1.
Question6
Puntos: 1
La lección 4 hace referencia a DfD el cual es un software que permite:..
Seleccione una respuesta.
Permite la construcción y análisis de los algoritmos
Correcto
Puntos para este envío: 1/1.
Question7
Puntos: 1
La lección 4 hace referencia a DfD, y el objeto que representa el inicio y fin del diagrama es:
Seleccione una respuesta.
El inicio y fin se representa con un circulo
Correcto
Puntos para este envío: 1/1.

1
Puntos: 1
para diseñar un diagrama que me perita determinar el área de un cuadrado, debo leer la siguiente información:
Seleccione una respuesta.
Correcto
Puntos para este envío: 1/1.
Question2
Puntos: 1
De acuerdo a lo revisado en la lecturara, una buena definición para algoritmo será:
Seleccione una respuesta.
La respuesta es: Una lista de instrucciones donde se especifica una sucesión de operaciones necesarias para resolver cualquier problema de un tipo dado
Correcto
Puntos para este envío: 1/1.
Question3
Puntos: 1
Si se desea realizar un diagrama para calcular la nota que debe sacar en el examen final del curso algoritmos para pasar la nota, los datos que debe ingresar son:..

Seleccione una respuesta.
Correcto
Puntos para este envío: 1/1.
Question4
Puntos: 1
En el algoritmo desarrollado en la lectura, la instrucción que permite generar números aleatorios es:?
Seleccione una respuesta.
La instrucción correcta es azar()
Correcto
Puntos para este envío: 1/1.
Question5
Puntos: 1
El siguiente algoritmo desarrollado en Pseint permite generar la tabla de multiplicar (del 1 al 10) de un determinado número, pero existe un error lógico en una de las líneas, debe seleccionar la línea en la cual se ha cometido un error de lógica


1 Proceso TablaDeMultiplicar
2 Repetir
3 I<-1;
4 Escribir "Introduce un número";
5 Leer Num;
6 Escribir " ";
7 Escribir "La tabla de multiplicar del ", Num, " es:";
8 Escribir " ";
9 Mientras I<=10 Hacer
10 Escribir Num," * ",I," = ",Num*I;
11 I<-I*1;
12 FinMientras
13 Escribir " ";
14 Escribir "¿Quieres volver a empezar. S/N";
15 Leer seguir;
16 Mientras seguir<>"n" y seguir<>"s" Hacer
17 Escribir "Tienes que escribir S o N.";
18 Leer seguir;
19 FinMientras
20 Hasta Que seguir = "n" o seguir = "N"
21FinProceso
Seleccione una respuesta.
El error esta en la línea 11, este es un contador sebe cambiar la * por un +
Correcto
Puntos para este envío: 1/1.
Question6
Puntos: 1
La diferencia fundamental entre un lenguaje algorítmico y el informático radica en:
Seleccione una respuesta.
El lenguaje Algorítmico es el que se utiliza para realizar un análisis previo del problema y el informático es el que es mas cercano a la máquina y al ser humano .
Correcto
Puntos para este envío: 1/1.
Question7
Puntos: 1
Un almacén desea obtener una serie de informes diarios a partir de las
ventas realizadas en un día. Elabore un algoritmo que:
Solicite el código del artículo
El valor unitario
La cantidad de artículos
El código para terminar es -999
Se desconoce el número de ventas que se realizan en un día, por lo que el final
de los datos se indica con un –1. Suponga que el IVA es del 15%.

si se utiliza el ciclo repita hasta que,, la condición para terminar debe ser:.. 
Seleccione una respuesta.
Correcto
Puntos para este envío: 1/1.
Question8
Puntos: 1
Si se desea realizar un diagrama que permita determinar el área de un pentagano conociendo su formula

area =( P * a) / 2

los datos que debo ingresar son:.....
Seleccione una respuesta.
Correcto
Puntos para este envío: 1/1.
Question9
Puntos: 1
La diferencia fundamental entre los ciclos
REPITA
----
HASTA QUE
Y el ciclo 
MIENTRA QUE
----
FIN MIENTRAS
Radica en:
Seleccione una respuesta.
En el Segundo de los ciclos necesita ser evaluado su condición para poder ingresar y el Primero NO
Correcto
Puntos para este envío: 1/1.
Question10
Puntos: 1
Para el caso del ejercicio: Una persona recibe un préstamo de un banco por un año y desea saber cuánto pagará de interés al terminar el préstamo si se sabe que el banco le cobra una tasa del 1.8% mensual.

los datos de entrada necesarios son:---
Seleccione una respuesta.
Correcto
Puntos para este envío: 1/1.

1
Puntos: 1
La definición más aproximada a un contador es:
Seleccione una respuesta.
Correcto
Puntos para este envío: 1/1.
Question2
Puntos: 1
Que hace el Siguiente Programa

PROGRAMA ejercicio
Entero: numnum2resp
Inicio

num = 1
num2 = 1
MIENTRAS num < = 10
MIENTRAS num2 < = 10
resu = num * num2
Escribir num, “x”, num2, “=”, resu
num2 = num2 + 1
Fin _ mientras
num = num + 1
Fin _ mientras
Fin
Seleccione una respuesta.
Incorrecto
Puntos para este envío: 0/1.
Question3
Puntos: 1
Si se desea realizar un diagrama para calcular la nota que debe sacar en el examen final del curso algoritmos para pasar la nota, los datos que debe ingresar son:..

Seleccione una respuesta.
Correcto
Puntos para este envío: 1/1.
Question4
Puntos: 1
de las características del lenguaje de programación c++ es la posibilidad de reutilizar código, esto significa que: (selecciones 2 opciones)
Seleccione al menos una respuesta.
Correcto
Puntos para este envío: 1/1.
Question5
Puntos: 1
Dada la siguiente tabla para el cálculo de la tarifa básica del servicio telefónico:
Estrato
Tarifa Básica ($)
1
10000
2
15000
3
20000
4
25000
5
30000
6
Con que estructuras lógicas, representadas en sentencias del lenguaje C++ o C#, se podría realizar el cálculo de la Tarifa básica, conociendo el estrato.
Seleccione al menos una respuesta.
Incorrecto
Puntos para este envío: 0/1.
Question6
Puntos: 1
Un programa en lenguaje C o C++normalmente no tiene:
Seleccione una respuesta.
Correcto
Puntos para este envío: 1/1.
Question7
Puntos: 1
Un Algoritmos es una secuencia de pasos lógicos que tienen un inicio y un fin, y en los cuales de puede contener:
Seleccione una respuesta.
Correcto
Puntos para este envío: 1/1.
Question8
Puntos: 1
Si se desea realizar un diagrama de flujo que permita encontrar el área de un cuadrado cuya formula es Area = L * L , las variables a leer son:
Seleccione una respuesta.
Correcto
Puntos para este envío: 1/1.
Question9
Puntos: 1
de las características del lenguaje de programación c++ es la posibilidad de reutilizar código, esto significa que: (selecciones 2 opciones)
Seleccione al menos una respuesta.
Correcto
Puntos para este envío: 1/1.
Question10
Puntos: 1
Selecciones 2 de las siguientes definiciones que más se ajusta a lo que es un Algoritmo
Seleccione al menos una respuesta.
Correcto
Puntos para este envío: 1/1.
Question11
Puntos: 1
Si se desea realizar un diagrama que permita determinar si un numero determinar realizar el cambio de moneda de pesos a dolares, la formula correcta a aplicar es:

Teniendo encenta que el cambio esta a 1800 pesos por dolar..
Seleccione una respuesta.
Correcto
Puntos para este envío: 1/1.
Question12
Puntos: 1
Dado el siguiente algoritmo:
Algoritmo notas_v1
Var
k : entero
suma, nota, promedio: real;
inicio
suma=0; k=0;
mientras (nota <>0)
repita
escriba("entre la nota");
lea(nota);
si (nota <0) o (nota >5)
escriba("Error. intentelo nuevamente");
fin_si
hata que (nota<0 ) o (nota >5);
if (nota <>0 )
suma=suma+nota;
k=k+1;
fin_si
fin_mientras
promedio=suma/k;
escriba("la cantidad de notas ingresadas son: ”,______);
escriba(“el promedio de las notas es de :”,_______);
fin
Cuáles son las variables que deben ir en los espacios
1. nota
2. K
3. Promedio
4. suma
Seleccione una respuesta.
Correcto
Puntos para este envío: 1/1.
Question13
Puntos: 1
Que valore se obtienen en la variables a,b,c , después de ejecutar las siguientes acciones:
 a=20
b=30
c=a+b
c= a+(a-b)
a=b-2
b=a
Seleccione una respuesta.
Correcto
Puntos para este envío: 1/1.
Question14
Puntos: 1
al variable que permite almacenar los datos de un una resultante de operaciones sucesivas y repetitivas y con incremento o decrementos variables se denomina:...
Seleccione una respuesta.
Correcto
Puntos para este envío: 1/1.
Question15
Puntos: 1
Los diagramas de flujo permiten la representación gráfica de un flujo de datos en un programa, la representación de un rombo es :
Seleccione una respuesta.
Correcto
Puntos para este envío: 1/1.

Comentarios

Entradas más populares de este blog

PENSAMIENTO LOGICO Y MATEMATICO

PENSAMIENTO LOGICO Y MATEMATICO

PENSAMIENTO LOGICO Y MATEMATICO